メインメニュー
ログイン
ユーザ名:

パスワード:



パスワード紛失

新規登録
TOP  >  更新日記(更新情報)  >  boomboom  >  サイト告知  >  PHPのVer

boomboom さんの日記

 
2011
5月 9
(月)
10:40
本文
今までPHP5.3系でこのサイトは動いていた。
正直5.3系は難がありすぎなのだがセキュリティ的に考えれば新しいVerの方が良いに決まっているので難がありながらも5.3系のまま使用していた。

しかし最近僕が遊んでいるネトゲのギルドでアンケートが必要になって設置したのだが、
あのスクリプトは不具合が露呈してきた。
他にいいスクリプトは見つからなかった。

唯一このサイトで使っているXOOPSのモジュールで良いアンケートモジュールがあり、
その不具合のあったスクリプトを設置する前から実はそれに目を付けていた。

が、PHP5.3系ではそのモジュールは動かないので上記で書いた不具合のあったスクリプトを使っていた。(後々XOOPSのモジュールの方で動けばそれを使いたい気持ちもあったのでURLで混乱しないようにこのサイトのURL上に設置してた)

しかし上記で書いたスクリプトに不具合が出てきたので結局PHPのVer自体を5.2系にダウングレードしてXOOPS用のアンケートモジュールで動かすことにしたのだ。

今のところアンケートモジュールは問題なく動作してるようで今後いいのが見つかるまではこれでいくつもりだ。

ちなみにそのアンケートモジュールはこのサイトで登録してもらい、僕がそれを承認し、更にグループをそのギルドメンバー用のグループに設定しないと見えないようにしてるのであしからず
閲覧(10440)
コメントを書く
コメントを書くにはログインが必要です。
Copyright © 2001-2017 boomboom-mix.com